??!
2 photos
Bestway Lay-Z-Spa Inflatable Hot Tub

Bestway Lay-Z-Spa Inflatable Hot Tub Questions & Answers

4.2 from 59 reviews

80 questions from our users

kellyb

kellybasked

Hi, I have a palm springs hydrojet. I brought it last year but placed it in storage over the winter. Since setting it up in april it constantly has either an E02, E04 or E08 come up on it. I have tried resetting, emptying it and re filling, cleaning everything but nothing seems to work. Any help would be appreciated. Thank you

No answers
Trisha Feenan

Trisha Feenanasked

Hello I’ve just bought a Bestway Moritz Hot tub spa of Groupon
I know it wasn’t from you guys but your a bestway rep
I inflated yesterday filled with water and started to heat but was still to cool to hop in so I went out this morning to put heater on and it has gone down not all the way of corse but sides are soft and worried it might go completely down over a few days causing the water to spill out
Is this supposed to happen will I need to undo filter to pump up every morning
Can you please advice Trish

No answers
Michelle H.

Michelle H.asked

Hi my partner was in a bad mood and has taken out the fuse in my lazy z spa Hawaii and will not give it back please can someone help which fuse is needed as I obviously don’t want to get the wrong one thanks Michelle ps the hot tub is 2 years old

No answers
Vincent B.

Vincent B.asked

Hi Brought Lay z spa last week only set it up to find out eo2 message keeps beeping.
Ask the guys from Gumtree said I had warranty in box. Can't find in box, now there not answering my messages.
II have done everything to try to deleted code buy nothing happening, wondering if service repair place here in Australia

1 answer
Bestway
Official R.Bestway

Hi Vincent,
Please Email our tech team with details of how you purchased it and what model you have at service@bestwaycorp.com.au
They will be able to assist with this.
David

Jac

Jacasked

Just purchased a Miami hot tub and trying to set it up, however, when I plug it in nothing happens atall, only when I press the rest button on the plug the pump lights up, but just continues to bleep with 6cf lit up on it. Even if I follow the thermal reset etc nothing happens, do u know what I can do to fix this? Can’t even pump up the hot tub to start. Seems like an electrical issue?

1 answer
Bestway
Official R.Bestway

Hi there,
Please Email our tech team at service@bestwaycorp.com.au
They will be able to assist with this.
David

Amber J.

Amber J.asked

I have a - Palm Springs spa. And I'm missing the inflation hose is there any other way to blow it up because you cannot buy a hose the us from the UK apparently?

1 answer
Bestway
Official R.Bestway

Hi Amber, where are you located?
David

Mandy B.

Mandy B.asked

I have a lazy spa vegas and the plug has got so hot that its melted the fuse and cracked the external plug socket. Is this a manufacturing issue with the vegas model?

3 answers
Bestway
Official R.Bestway

Hi Mandy, can we know where you purchased this spa from?
David

Mandy B.
Mandy B.

I purchased it from Homebase

Natasha E.
Natasha E.

Mine has also done the same in both my outside plug sockets now have gone yellow and cracked ..
Is there a reason for this!!!!

Philip Varty

Philip Vartyasked

My spa has split along the seam we’re the air comes out to make the bubbles any way to fix this? thanks Phil

2 answers
Billie
Billie

Hi, did you manage to sort this problem as I have same issue too

Bestway
Official R.Bestway

Hi there,
Please Email our tech team at service@bestwaycorp.com.au. They will be able to assist with this.
David

Shona M.

Shona M.asked

We have the Palm Springs spa, bubbles work, but when we turn on the heat and filter it displays EO2 what can we do to fix this issue ASAP and where do we get this problem solved with the spa??

2 answers
Philip Varty
Philip Varty

Clean the egg out put a hosepipe in the egg let water run throw for 15 mins then change the hosepipe to the other hole then let the water run the other way for 15 mins that cleans the egg then make sure the pipes what goes it to the hot tube are clean no bits ov rubbish etc use a toothbrush to clean them in side the pool

Bestway
Official R.Bestway

Hello Shona,

An E02 is usually a quick fix:

1.Take off both the filter housing and run the pump on filter or heat modes. If it doesn't trigger the E02 then it means the filter cartridge in the housing was too dirty and will need replacing. If running it without the filter housing still triggers the E02 then please proceed to the next step.

2. Please attach stopper caps to the spa and disconnect the spa pump from the spa. Check for kinks in all hoses, notably hose B at the bottom for any kinks. Often kinks are formed due to the pressure of the water and the air engulfing the hose. The hose can be partially kinked only to cause the E02. In this case please un-kink the hose or use a plastic tube (plumbers tube) to wrap the hose to prevent kinks forming again.

3. Try resetting the pump. Reset can be found here: http://prntscr.com/q6unc6

4. If E02 persists, please connect the pump to the spa again and take off the stopper caps. Place one hand over the outlet and press Heat. In the split second before the pump goes into E02 please verify and let us know if any water movement is detected from the outlet?

5. If the steps above didn't work or you have any further tech queries, please contact contact us and we will assist further.

Tanyas J.

Tanyas J.asked

Hi why does my lock keep coming on on my lazy spa?

1 answer
Bestway
Official R.Bestway

Hi there,
Please Email our tech team at service@bestwaycorp.com.au. They will be able to assist with this.
David

Kelli

Kelliasked

Just set up Miami model and it won't heat up past 29 degrees... Suggestions?

1 answer
Ryan
Ryan

When we first filled it we had access to hot water, so we filled it with both hot and cold, we then put the heater on! It goes up to 40 on ours and slowly goes down a few degrees while using it. Put the lid back on with heater on and it goes back up to 40.
From what I read you need to leave the heater on for a day to heat up if using cold water when filling.
Good luck.

Greg Campbell

Greg Campbellasked

Hello, we have a Lay-Z-Spa by Bestway, model # 14294 The problem I have, is the air pump is no longer working & there burning smell coming from it, the filter & heat part still works , just no air pump, We bought the unit from ALDI'S about 1& half years ago,but no longer have the receipt . Where can I get a replacement pump, & what would it cost , in Victoria Australia? You can email me at [email address removed] . Regards Greg Campbell

3 answers
Bestway
Official R.Bestway

Hi Greg, strongly suggest to edit your comment and remove the S/N please. This should only be shared with us directly, however this is a public user forum.
Please Email our tech team at service@bestwaycorp.com.au
They will be able to assist with this.
David

Greg Campbell
Greg Campbell

David, I have tried several times now to send an email to the link you provided, but for some reason it wont go threw , I have also edited my original post as per your request. I would still like a solution to the problem I have with the pump. Greg

Bestway
Official R.Bestway

Thanks Greg, appreciate that.
Apologies as it could be the way I typed the Email stopping it from going through. It shouldn't have a dot (.) at the end, correct Email is:
service@bestwaycorp.com.au

I've edited my reply to reflect the correct Email now.

Can you try that and let me know if you still have issues getting through.

David

Lee W

Lee Wasked

Hello, I have a Maldives Hydro jet. Today we put on the hydro jet and it started emptying the pool and also inflated the liner. Can you assist please?

1 answer
Bestway
Official R.Bestway

Hi Lee,
Please Email our tech team at service@bestwaycorp.com.au. They will be able to assist with this.
David

steve farrell

steve farrellasked

hi we have a dog how durable are these spa if he happens to jump up on it
Regards

1 answer
Bestway
Official R.Bestway

Hi Steve,
The spa walls are certainly strong and thicker than other typical inflatables in the market.
Despite this, as a precaution I would still advise against letting pets around the spa.
David

Claire

Claireasked

I'm trying to inflate my lazy spa but the air is coming out of the holes inside the pool can anyone give me advice as its deflating straight away

3 answers
Billie
Billie

Hi did you get an answer for this as I have same problem

John S.
John S.

I also have this issue

Eve H.
Eve H.

Also having this problem, any answer on this issue?

Spees

Speesasked

We have a 54138 Lay-Z-Spa Hawaii HydroJet Pro spent alot of money on it and it has started to leak water from around the bottom pipe. Hardly used. Double checked the connection to pump and is firmly in place with seal. Guessing it could be coming from inside the liner of a pipe connection. Does anybody know what could be causing this leak, the water level disappears in roughly a week. Any help appreciated to problem solve issue.

1 answer
Bestway
Official R.Bestway

Hi there,
Please Email our tech team at service@bestwaycorp.com.au. They will be able to assist with this.
David

jennifer a.

jennifer a.asked

Lay-z-spa Vegas, was sisters, we have had running perfectly for two days. Today it is tripping the house fuse as soon as I turn it on. Was running when this first happened. Thanks, Clara.

1 answer
Bestway
Official R.Bestway

Hi Clara,
Happy Easter :)
For tech queries please contact service@bestwaycorp.com.au. Our tech team can help.
David

Clem670

Clem670asked

Hi I have just set up my hawaii hydrojet pro and when I turn the filter on it leaks from the pipe.I have tried repositioning it and sealing it as tight as I can but to no avail...can you help?

1 answer
Bestway
Official R.Bestway

Hi there, for tech queries, please contact our tech team at service@bestwaycorp.com.au. They will be able to help best.
David

Howard R.

Howard R.asked

I have a Miami when I put the massage system on there is no bubbles coming through and it sounds very loud when I disconnect the pump it is not as loud and there is air flowing okay what can I try?Thank you very much

1 answer
Bestway
Official R.Bestway

Hi Howard, for tech queries, please contact our tech team at service@bestwaycorp.com.au. They will be able to help best.
David

Amanda

Amandaasked

Hi

I have a Maldives spa which I have attempted to inflate today however there doesn’t seem to be any power getting to the pump. The light on my switch is on but no light on the unit. When I press test nothing happens but when I press reset I hear a click and see a flash of light but nothing happens. I have tried pressing reset on the unit too and the fuse is okay. Can you please advice if there is anything else I can try?

My spa was purchased in July 2017 and has only been used on around 6 occasions for 2 weeks at a time so I’m very surprised that we are having problems. It has been stored in the garage in between coming out in fair/good weather.

1 answer
Bestway
Official R.Bestway

Hi Amanda, sorry to hear about the issue.
Our tech team can take a look into this and help. Please contact us at service@bestwaycorp.com.au to further help.
David

Page 1 of 4

Get an answer from our members and Bestway representatives

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.