??!
5 photos
BMW X5 E70

BMW X5 E70 (2007-2013) Questions & Answers

3.8 from 26 reviews

33 questions from our users

Ray

Rayasked

X5 E70 (2007-2013)

im having issue with my x5 E70 2008 model as a warning light came up saying sos system not working then immediately after this notification my Bluetooth as well as rear view camera stop working any ideas what maybe the cause ?

No answers
AJOSH

AJOSHasked

X5 E70 (2007-2013)

Driving BMW X5 3.0SI since 4 months, after slowing it down came to stop at signal, suddenly car shuts off and automatically shifts to neutral. scary as i was in the traffic. again i started it and put in D mode.
Happened with anyone here please suggest.. this is for 2 -3rd time..

No answers
Lucas G.

Lucas G.asked

X5 E70 (2007-2013)

The car will drive for a short distance and switches off, when started for the first after switch off it does not start but only start on the second try, but when gear is engaged it switch off. After a 3 hour period of waiting the car will move, and it will repeatedly continue the same with faulty. Please advise?

No answers
Richard Walker

Richard Walkerasked

X5 E70 (2007-2013)

My BMW X5 3.5 D E70 XDrive MY 2009 has just completed 150,000 km and has a big end bearing and con rod failure in No 3 cylinder . It was bought new and has been serviced by BMW all of its life .Prior to this happening it was making a squealing noise for a few seconds when cold and the particulate filter light warning came on. I reported this to BMW and they changed the glow plugs but could not identify the cause of the squealing . I expected this engine to last at least 300,000 kms if not more. Has anyone else encountered a big end bearing failure ?

No answers
Shaun 1508

Shaun 1508asked

X5 E70 (2007-2013)

My 2008 BMW X5 cutting out whilst driving then will not start but if I take key out and put back in it start. Any help?

1 answer
Zilvinas S.
Zilvinas S.

Have you find out your problem? Few years ago i had same problem, that end up to change injector nr. 5 because on x5 there is water leack from Windows

Gary C.

Gary C.asked

X5 E70 (2007-2013)

whats with the timing chain 140 k needs replacing should do 500k

1 answer
tryingtoslowdown
tryingtoslowdown

Where did you get that information? I've done well over 200k now and not been recommended to do it

Chris

Chrisasked

X5 E70 (2007-2013)

I am considering the purchase of either a second hand E70 X5M or X5 50i, 2012 or 2013 model.
Is there any issues with these vehicles that I need to be aware of? Chris

1 answer
IMD
IMD

YES!
I'm in Australia & replaced my 2004 X5 4.8Si with a second hand 2009 X5 50i with 60,000Km in 2013. After 18 months at 70,000Km, the engine warning red light came on though the car drove normally. My independent mechanic said the codes indicated VANOS & turbo problems but he was reluctant to work on it as it was driving normally & the risks in dissembling it could make it a very expensive repair. Another independent mechanic erased the codes but the red light came back. I then read about the bad reputation the twin turbo V8 had, sold the SUV (at a a loss) & bought a 2012 X5 M50d (not sure if they sell these in USA). Very happy with the M50d - apart from a 1/4 sec. turbo lag on takeoff, performance is every bit as good as the V8 & I've had no problems at all with it. Fuel consumption is 8.5 liter/100k - the V8 was 13.5!

Good luck but I'd avoid the twin turbo V8.

Steve c

Steve casked

X5 E70 (2007-2013)

I have a bmw 2007 x5 e70 3.0d. I start it and it will tick over for like 10 minutes then shuts off, I remover the key start it again then it starts but dies straight away. This happens over and over . The next morning it did the same. Any ideas please?

1 answer
Dolorado
Dolorado

Hi Steve,
Mine had the same problem and we found it was the MAS (Mass Airflow Sensor) then ran perfectly afterwards. I sold it before something else went wrong. :-)

Striney Pillay

Striney Pillayasked

X5 E70 (2007-2013)

My E70 3.0 SD X5 loses power after a long trip , I can still drive it but when I depress accelerator the response is poor , like no boost

No answers
Sydney C.

Sydney C.asked

X5 E70 (2007-2013)

Hi my 2007 BMW x5 3.0 d cuts off while driving. I replaced all fuel related sensors, fuel regulator, fuel pressure, fuel measure and the fuel pump. But it still do the same. It will start and cuts off after some few minutes. It shows the low battery warning signs and lose time and date. Can a low battery cause the car to cut off while running? Please help I am frustrated

1 answer
Don S.
Don S.

Most engine management systems require about 12 volts to function correctly. If voltage is low it will shut down. X5's apparently require a good battery and some people recommend AGM batteries for longer battery life.

norrie

norrieasked

X5 E70 (2007-2013)

Where is the ignition coil situated in a bmw x5 e70 3.0sd?

1 answer
Martyn
Martyn

Its diesel,it has no ignition coil. It has glow plugs insted of spark plugs.

Rafeek G.

Rafeek G.asked

X5 E70 (2007-2013)

My x5 e70 30d 2008 drives has power loss and severe black smoke this happens after I drive it for a while then park it and when I I drive it again after an hour this happens but when the van stands overnight and I drive it then it’s fine. Any help?

No answers
BenMC

BenMCasked

X5 E70 (2007-2013)

Hi All,
I have just purchased a 2010 X5 Diesel with 110,000km. Was driving fine (had done 300km in it) then cut out going up a steep bridge. The ignition was still on and it turned over but wouldnt start. popped the key out and put it back in then it re-started. Filled the tank with fresh diesel, but still kept doing it. Got to a workshop, cam up with a bunch of old history codes, but the most recent was (Injector 5 fault) cleared them and test drove, sometimes it would drive for 30 seconds, then other times 20 minutes. This X5 has had a DPF delete done, but that was a while ago according to the old owner. It sat over the weekend then came up with a fault on the screen stating (Fuel pump issue, see dealer) The workshop has been trying a few things and now is has a transfer case fault, I cant see how that would make the car stop. Any thoughts? I read that a lot of people have the Injector 5 fault, but does replacing that fix anything?
Thanks in advance

4 answers
Healing plants
Healing plants

My Dads Honda used to do this a while back I think he tried changing everything, but found out that the problem actually was in the ignition barrel once he changed it all it was perfect again. Hope u find out what’s causing it

Phantom
Phantom

soumds like you have a common issue where water gets into the top of number 5 injector and corrodes the sensor on top of the injector itself. They some time just change 5 and 6, sometimes suggest change all. The plastic guards running above the back of the motor that keep the water from running into the engine bay under the bonnet fail/leak and let water drip onto the back of the motor.

BenMC
BenMC

Yep, thats what it was. I found a great BMW mechanic in Melbourne how diagnosed it and sorted it out for me.
I then hit a kangaroo in it 2 weeks later and its in the panel shop....I think its jinxed :-(

Tony

Tonyasked

X5 E70 (2007-2013)

Need some help. Dealer scan and doesn´t really know why it happens. Got X5 xdrive premium 3.0TD, 2011. It gives an engine fault, a yellowish message with half an engine drawing, then it says: full engine power no longer available. Possible to continue journey. Drive moderately. Have the problem checked by the nearest BMW dealer. Problem is, the dealer can´t figure out what the problem is. It got worse when we took it to the beach, here in Costa Rica, the temperatures were at 96F, and that worsen the problem. What it happens is that when I step on it an the revs reach around 3000rpm, it trouble shoots and you can feel the engine actually looses power. When slowing down, then the message disappears and the car keeps running, apparently normally. Except when I tried again to accelerate, it happened again. Does someone knows what the problem might be? thanks.

No answers
Gary P

Gary Pasked

X5 E70 (2007-2013)

Timing Chains any issues ?

1 answer
Martin
Martin

Had no issues so far - nothing picked up in the annual services. Could be a nasty surprise later down the track? I'll be turning the car over in September for the new shape.

Rhoda

Rhodaasked

X5 E70 (2007-2013)

What are the sign if your car needs a battery replacement, I have a BMW X-5 3D 2007 in this past few days it's giving me beep while driving aside from the resetting of clock/date every now and then.
Do you have any answer on this?

No answers
Rhoda

Rhodaasked

X5 E70 (2007-2013)

I have this BMW X-5 3D, the keep on asking me set clock/date,it just happening this few weeks. How do I resolve this problem?..please give some answer

1 answer
Arsh G
Arsh G

This indicates a low battery. Unfortunately the only solution is to replace your car battery.

zaman

zamanasked

X5 E70 (2007-2013)

Hi every one .2008 BMW X5 3.0si have starting problem ! mostly second time or 3d when I stop to take gas or go for 5/10 minutes stop the engine then its seem like hard to take start and some time it doesn't !! I already bought a motor master battery eliminator by 300 $ then it was good for 2 days now it came back ! I when it start once every things working good no any other problems ...please help me ...

1 answer
Kim S
Kim S

Check the fuel sensor

Louis

Louisasked

X5 E70 (2007-2013)

Hello my BMW X5 e70 cuts out while driving losses all power I take the key out and put it back in it will start straight back up when I accelerate it cuts out again keeps doing it intermittently had injectors checked fuel pump checked but all ok any suggestions what it could be would be grateful if someone could give me some

6 answers
tray
tray

Hi did you find out what the problem was?
as ive had same problem .
ive had hp diesel pump .
diesel tank pump .
2 injectors changed .
still same problem .
any one any help

johnnykayal
johnnykayal

Hi there check the rail pressure sensor the front one

Kcv
Kcv

Check MAF sensor

Benzo

Benzoasked

X5 E70 (2007-2013)

My e70 3.0 xdrive exerts a cloud of black smoke when I increase the throttle from mid to full throttle what can the issue be? please help.

1 answer
karabo m.
karabo m.

One of the turbo pipes is broken or bit loss check that.

Page 1 of 2
See all BMW X5 questions

Get an answer from our members

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.