??!
2 photos
Holman Water Whiz 400

Holman Water Whiz 400

1.6 from 26 reviews · View Statistics

Reviews

1.6

26 reviews
Previous
Next

Reliable?

published

Product worked perfectly, then showed signs of poor power supply. Changed batteries, same problem. Put a thin cardboard packer in battery compartment to improve contact , end of problem. Such a brilliant design, other than poor connection.

Purchased in November 2019.

Incentivised ReviewNo
Daveo78

Daveo78Perth, WA

  • 5 reviews
  • 2 likes

Run for 12 months flawlessly

published

Had the 4 station Pope model and took it back after 1 week. One station just kept flowing everytime it turned on. Spent more on the four outlet Holman and honestly they are light years apart. 12 months later and it still has full battery. No issues. Fingers crossed it continues.

Purchased in October 2018 at Bunnings Warehouse for $150.00.

Incentivised ReviewNo
1 comment
Holman
Holman I.Holman

hello Daveo78, Thank you for your review.

See all Holman Water Whiz reviews

Questions & Answers

Paul Barlow

Paul Barlowasked

Water Whiz 400

This is my second Holman Water Whiz 400 and I am having the same problem. This one has served well for nearly 2 years. I have three outlets connected. Of late the Holman is leaking once again from the neck of the unit. The flat top of the white neck has broken off from the body of the main neck. Can this part be replaced? Or do I now need to buy a new one again?
Paul

No answers
Byron

Byronasked

Water Whiz 400

I Have a Waterwhiz 400 and the zone #1 will not close. I have tried the reset function, the manual running of zone #1 for 1 min etc, but it still will not close zone #1. When I run the manual function on zone #1 it almost instantly shows reset on a blank screen.
Your earliest attention will be appreciated.

1 answer
Holman
Holman I.Holman

Hello Byron, for product support, please contact us on 1300 716 188. Thank you, your Holman Team!

Nick M

Nick Masked

Water Whiz 400

My Water Whiz 400 keeps resetting the time by itself. I have it on Auto, when I come back to it is on 'set time' and the time has changed.
How can I stop it doing this please?

2 answers
DrDG
DrDG

Hi Nick, I have never experienced this issue myself. Have you tried to reset the Water Whiz and try setting the time again. To reset it, press and hold the OK button till the time is reset to 7.00am. The unit will be in default settings now. Also make sure that your batteries have a good charge and are not close to being dead.

Nick M
Nick M

Dear Dr DG
Thank you for your prompt response
I renewed batteries (they seemed OK) and reset as you suggested. Clock seems to work now - and switches on at the right times etc.
It runs the first channel, then gets stuck on the second - won't send any water now even on manual to channels 2,3 or 4. Channel 1 works fine.
Any ideas? Maybe a malfunction?
Nick

Get an answer from our members and Holman representatives

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.