??!
2 photos
Holman Water Whiz

Holman Water Whiz

400, 200, 100
1.7 from 44 reviews · View Statistics

Reviews

Previous
Next

Reliable?

published

Product worked perfectly, then showed signs of poor power supply. Changed batteries, same problem. Put a thin cardboard packer in battery compartment to improve contact , end of problem. Such a brilliant design, other than poor connection.

Purchased in November 2019.

Incentivised ReviewNo
Daveo78

Daveo78Perth, WA

  • 5 reviews
  • 2 likes

Run for 12 months flawlessly

published

Had the 4 station Pope model and took it back after 1 week. One station just kept flowing everytime it turned on. Spent more on the four outlet Holman and honestly they are light years apart. 12 months later and it still has full battery. No issues. Fingers crossed it continues.

Purchased in October 2018 at Bunnings Warehouse for A$150.00.

Incentivised ReviewNo
1 comment
Holman
Holman I.Holman

hello Daveo78, Thank you for your review.

See all Holman Water Whiz reviews

Questions & Answers

Paul Barlow

Paul Barlowasked

Water Whiz 400

This is my second Holman Water Whiz 400 and I am having the same problem. This one has served well for nearly 2 years. I have three outlets connected. Of late the Holman is leaking once again from the neck of the unit. The flat top of the white neck has broken off from the body of the main neck. Can this part be replaced? Or do I now need to buy a new one again?
Paul

No answers
Adrian Riccioni

Adrian Riccioniasked

Water Whiz

My holmans whiz 200 is leaking between the hose fitting and the body of the unit
How can I sort it out
Adrian

1 answer
Trebor
Trebor

Hi Adrian. Myriad possibilities and probably many you will have tried - but if it helps anyone? No knowledge of Water wiz 2, but looking at all my timers there would appear to common points. Let's start at the beginning. Disconnect any hoses and fittings attached to WWz. Turn off tap to unit and ensure unit is not set to supply water. Turn on tap. Is any water apparent. I have had a few issues with fitting to tap leaking, water dribbling down back and appearing at the bottom as a leak. If leaking from tap fitting, 'Nip' up tighness and check again. Check washer in connector and replace. Fixed?? OK no leak from connection. Is water still appearing at bottom - consider a hair-line fracture from either over -tightening connectors OR was unit exposed to frost. Get a new one and remove before your expected first frosts! No leaks, then check hose connectors on outlets. The rubber washers harden over time and either need a further 'nip' up from finger tightening, or replace the washers. Ensure hose is properly connected to hose connector and hose connector firmly 'snaps on ' to unit nipple connector.
Hope this has helped. Cheers.

Byron

Byronasked

Water Whiz 400

I Have a Waterwhiz 400 and the zone #1 will not close. I have tried the reset function, the manual running of zone #1 for 1 min etc, but it still will not close zone #1. When I run the manual function on zone #1 it almost instantly shows reset on a blank screen.
Your earliest attention will be appreciated.

1 answer
Holman
Holman I.Holman

Hello Byron, for product support, please contact us on 1300 716 188. Thank you, your Holman Team!

Get an answer from our members and Holman representatives

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.