?
? !
5 photos
Kawasaki Vulcan 900 Custom

Kawasaki Vulcan 900 Custom Questions & Answers

4.5 from 32 reviews · View Statistics

37 questions from our users

Dennis P.

Dennis P.asked

Hi.
I have a 2010 Vulcan 900 b.
It starts and run for app.10 seconds.
Then stops, restarts and does the same over and over,?
tilt over switch ? where would it be,
as I think it may be that it is faulty.
Dennis.

No answers
Mike

Mikeasked

My rear spark plug is more brown than the front plug ..does it run leaner in front than the rear I have a pc3 installed with advanced mapping ..is this normal also when I was running 87 they were white with little brownish after I changed to shell 91 it runs better but I’m not sure about the plugs being that color?

No answers
immanuel s.

immanuel s.asked

Can Kawasaki vn900 start without battery ?

No answers
Brandon

Brandonasked

I have a 2008 Kawasaki Vulcan 900 it wouldn’t start the other day so I gave it a jump it started but wouldn’t stay started I had the battery checked it was bad bought a new battery it started with no problem ride for bout a hr and it died out on me and now it continues to die out and I have to jump the battery every time. Do anyone have any suggestions?

1 answer
immanuel s.
immanuel s.

You have to check if the alternator is connected, an make sure the battery is charging.

Doug.p

Doug.pasked

I have a 09 kawasaki vulcan 900 it started bogging after 1/4 throttle so i put a new fuel pump and regulator and new stator coil and regulator and new battery i even took the injectors out and clean them put it all back together fired it up and run good for just little i walked inside to get my helmet and went back out was gonna ride it when i took off it started the same thing bogging. Any help?

3 answers
Martin B.
Martin B.

I have exactly the same problem after replacing the stator cover gasket. I read several post and the problem would be due to a bad groud inside the cover, a cut or damaged wire. Il check it out tomorrow. Give me a update and I'll do the same if the problem is solved. Good luck

Doug.p
Doug.p

i finally got around to check under the stator cover everything is good i even took the injectors out and clean them u recon it could be something going on with the ECU

al c.
al c.

What happened with this

Doug.p

Doug.pasked

I have a 09 kawasaki vulcan 900 it started bogging after 1/4 throttle so i changed the fuel pump in the tank didn't fix it i just put a new stator and regulator and new battery it cranked up and run good for about 30 minutes into my ride then it started slowly acting up again like it has bad gas or not getting enough gas i had to trailer it back home all it will do is crank and idle if i try to give it any throttle it starts bogging and spitting and popping any ideas?

3 answers
Jonesy
Jonesy

Check the coil,

Doug.p
Doug.p

i checked the coils they both are firing so i sprayed some carb cleaner in the breather it started as long as i was spraying that in the breather so i took the injectors out and clean them because i had already put new fuel pump in it got the injectors clean put bike back together it fired up and run good for just little then started bogging again could it be that one of the coils not putting out good after the bike warms up.

al c.
al c.

Any update

Ultjon K.

Ultjon K.asked

Can i put abs in a kawasaki vulcan 900 coustum? 2020

No answers
Ibrahim O.

Ibrahim O.asked

My kawazaki vaulcan 900 just trip off what can cause it?

No answers
James G.

James G.asked

Can some one tell me i have replaced the front pulley on my VN 900 and i want to replace rear does this make a big difference

No answers
Kams

Kamsasked

what size spark plug wrench fits kawasaki vulcan 900 classic 2015 year model?

No answers
Hershel

Hershelasked

I have a 09 Kawasaki Vulcan 900 classic I'm getting fuel I'm getting fire it will start up run for about 3 seconds then shut-off and will not start back up for about 30 minutes then it will shut off again can somebody explain please I have replaced fuel pump and the battery and the fuel injectors I have replaced a throttle body and the fuel pressure regulator valve

1 answer
lamar
lamar

are you getting enough fuel to run on or is gone. are the plugs wet when it quits . Now that could be fuel screen or something restricting the flow for continues running. Now it could be short burst of electricity. Other than that how is the compression. One last thing how is the air cleaner. I would like to hear what the problem is .

Good luck hope this well help.

Mogul

Mogulasked

Will a 2013 Kawasaki Vulcan 900 be able to keep up with a mc that I’m going to be joining they all go 80-80+ on the highway for long rides?

2 answers
lamar
lamar

You will pushing it very hard mine runs 100mph but it takes a little time to reach not bad though. I would like to see little bigger bike. You'll be at close to high 7000 to 8000 rpms. So I'll let you go from there. Other than that you are ok. Nine only has 3600 miles on it may it gets better as miles add up.
Thank you for asking

Bonks
Bonks

What kind of mc are you joining that doesn't stipulate English/American bikes only?

Short answer, yes you can. Long answer, it's not the most comfortable, and the bike isn't designed for it.

Danny

Dannyasked

2007 Vulcan 900 custom will not fire unless put gas to throttle, throwing code 56 radiator relay fan could this make it not run. Any ideas?

2 answers
Bobby J.
Bobby J.

did you ever figure out the issue with the 56 code?

Shaun M.
Shaun M.

It's the fan fuse

Deric

Dericasked

How to tell if your motor is bad?

No answers
Shocky

Shockyasked

Hi Everyone, can anyone tell me if you can swap out the rider foot pegs with aftermarket floorboards on a 2017 Vulcan 900 custom, and if so how hard is it to do? Also anyone know an actual store in Qld Australia that you can purchase Knee high (not over the knee) riding boots? I need a pair to use for riding as my right calf blisters on long rides. Thanks Shocky

No answers
Steven S

Steven Sasked

I have an 08 Vulcan classic. I rode it two days ago and it seemed fine but today it wouldn't start and the battery seems to have been drained. I do have a boss 420b amp and speakers hooked up but I've had it for a while and haven't had any problems. It is connected properly to an accessory wire so it turns off when the bike does. My uncle tried his battery charger hook up and it fired right up then, when he disconnected it my bike stopped. I was rear ended two weeks ago in which my fender was broken and my right turn signal lamp was popped of the assembly but still connected wire wise and still works. Could it be that that light is causing a short or what else could it be?

1 answer
Bonks
Bonks

Either your regulator or your stator is shot. I had to replace my stator after 40000 klms, doing the same thing as yours. Apparently it's quite a common problem, but seeing as it usually goes "out of warranty" the company never bothered to fix it.

Tammy

Tammyasked

Hi everyone
My Kawasaki VN fuel pump went so I ordered a new pump connected it all up and did I not see a small piece of plastic was missing near the pump wires so the bike shorted out. I had to get another complete pump with the ome or housing it sits iin and I blew one fuse being the pump fuse, so replaced it. Now when iv put it all back together the pump is making a continuous noice and still won’t kick over. The relay fuse looks ok to me however I do t know about the relay itself. What do u think guys?
Any help appreciated. Thanks

Tammy

No answers
DIABLO.

DIABLO.asked

I have a 2007 Vulcan 900 I was riding it yesterday then it died on want to turn on but dies I hear the pump turn on and it also let oil from the carb cover when I removed it Please Help Me Thank You.

2 answers
Werewolf
Werewolf

I'm not sure but I think you have a seal bad.I would take it to the Kawasaki shop or a good mechanic.

Bill D
Bill D

It's oil from the emissions system overflow...mine does the same thing..go on You tube and look for the video that shows a small fix for this by placing a hose into the drain hole inside the air filter cover..

Shocky

Shockyasked

Hi everyone have got a 2017 VNCustom 900 and I want to know if anyone out there has had their bikes debaffled? If so has it affected the performance at all and what does it sound like?

3 answers
Michael Ripke
Michael Ripke

I have a 2007 custom with a Cobra system and no baffler at all. Noisy as hell. Performance is still good. Only drawback is the backfire I got by deceleration . Need earplugs though when I drive .

Bonks
Bonks

What he said. Noisy as hell and you lose power. Engine revs free'r, as to be expected. Had Vance and Hines full exhaust on mine

Shocky
Shocky

Hi all just thought I would let everyone know that we had our vn900s debaffled and could not be happier. Better performance, certainly does not run as hot and better fuel consumption. Oh and they sound awesome.

gazza

gazzaasked

i have a 2008 vn900 vulcan classic. was running fine. parked it and next time i went to start it nothing at all from the starter switch. battery is fine and i put in a new starter relay. still no go. all fuses are ok. has me buggered. what could be wrong?

1 answer
Michael Ripke
Michael Ripke

Check the relay under the clutch lever as they wore out over time. The connector disengage the info to the starter motor that you are in neutral, therefore giving info that Bike is still in gear and stand is out.
Hope that helps

Page 1 of 2

Get an answer from our members

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.