??!
5 photos
Mitsubishi Express

Mitsubishi Express Questions & Answers (page 5 of 12)

1986-2005 and 2006-2013
3.9 from 29 reviews

233 questions from our users

Does anyone know where the tailight relay is located on a 1999 2L express van?
No answers

Hi I own a carburetted mitsubishi starwagon. Runs great with only 176000 on the clock. Just had the fuel pump replaced and now it runs as though its starving of fuel. Mechanics said the carby need tuning but was fine before it went in for the fuel pump. Is this correct or have they done something they shouldn't have?
No answers

Hi all, I would like to know how to replace the stereo in my 2005 express. How do I remove the old one, where are the screws? Thanks
No answers

1990 SW, LPG converted. Loud backfire just yesterday whilst driving on Petty but quickly lost all revs and decided to cut out. Re started on gas and all seems ok. Fuel Pump? Or something more sinister? Thanks in advance mate, Allister
1 answer
Backfire indicates a lean mixture. Sounds like it just gave up on petrol.

Fuse for mitsubishi radio 2008?
No answers

Hi All ,my ventilater stopt working on my mitsubishi express(2009) ,checked the resistor and changed it ,still no ventilater/blower any body any ideas? cheers.
No answers

Have a 2008 Mitsubishi Express that I've just bought and it seems to have an odd wiring set up or possible alternator issue. The stereo, clock, windscreen wipers, cigarette lighter and interior lights don't turn on until the engine is running and revving high. Often if I stop at an intersection or drop the revs they turn off. Yet the dash lights, headlights and rear cigarette lighter (powers fridge etc) work as normal. Where do I start?
1 answer
Tighten the alternator drive belt.

I have a rattle that sounds like a object is rattling in the air duct fan, on the passenger side especially when the setting for air is set on 'arrow to face' icon. What is the best way to crack it open and get it out?
1 answer
Sadly the only way to get in there is to remove the instrument Cluster disconnect the plugs, and then see if you can reach in but you will likely have to remove a large part of the dash. Depending on where in the air duct the rattle is.. to remove the instrument Cluster you have to undo the screws. Put the steering wheel on lowest setting, pull off the covering part of the dash, just enough so you can disconnect the clock. then disconnect clock so you can remove the cluster cover part of the dash. After that you have to remove the screws on the cluster which mount it to the dash. Pull the cluster forwards slightly, then disconnect the plugs on the back.of the instrument Cluster carefully.. once you have all that done there is a right angle corner of the air duct on the right.. up high.. you can pry it off there.. hopefully it's something stuck in that section. Because if it's not. It means removing the rest of the dash accessible clips and pulling the pieces of duct apart at each join until you find the issue. Saying all of this. It may just be a loose screw. So check each clip and screw behind the instrument Cluster as you work. Good luck.

Whenever I restart the engine my clock resets itself, how could I go about fixing this? My stereo also resets and will only activate when the engine is running, thoughts?
No answers

Hi, i have a 1982 L300 with a manual transmission in it and i also have a 97 SJ express that is automatic, was wondering if i can swap out transmission as i have issues with my left leg and cant drive a manual anymore. I am wondering how many holes are for the flywheel flex plate on the 97 model, is it 5 or 6?
No answers

Hi i have done service L300 , then i notice oil leaks from drain plug , then i replaced new washer, But still leaks , Is this common issue of this model?
2 answers
Might have cross threaded the bolt. Sure you could use some thread tape of some sort or replace the bolt see if that worksHi there thankk you for reply. I used an oring with washer. looks ok now. Thank you ilham

Where is the fuel filter located in a 2007 Mitsubishi Express 2.4L?
2 answers
Follow the fuel line from fuel tank. The filter is Just past the fuel rail usually. Near the starter motor.Thanks, found it and replaced without too much trouble

Hey guys, I have a 1991 mitsubishi starwagon 2.4 litre and one of the negative battery leads have come off from somewhere and one is grounded in the engine bay but one is just hanging. Any ideas where it's supposed to go? Thanks
2 answers
If it is original earth lead .. half way bolts to the body and the end bolts to the engine. - JamieYep. Just to the left of battery inside engine bay is a little mount. E.g.. bit of a flat mounting spot. With a bolt hole. Should be easy to find. As it will line up..

Hello guys and gal's. I have a SG star wagon and was wondering where the blinker flasher relay can be found?
1 answer
Just to the right of the fuse box .. Jamie

Hello I have a 2005, 2ltr Petrol SJ express van, I just recently purchased it. But I don’t have a owners manual would anyone have any idea on what oil you recommend and how much oil to put in engine? thanks
2 answers
Looks like RST 202 oil according to me google.10w-40 is ok .. no more than 4litres (3.8) depending on whether you change the filter .. Jamie

Hi Guys I have a 2007 Mitsubishi Express SJ Series van. Can someone advise me how to replace the alternator belt? I am difficulty loosening to the power steering pump so I can remove alternator belt
1 answer
Why? I've got one van that's approaching 900k and another done 500k and haven't replaced a belt on either. Probably got replaced with engine rebuilds which I do at about 300k+/-.

Hi Where can i download Mitsubishi Express van SJ series workshop manual pdf
No answers

Brought a 2000 express van last week and forgot to ask them what oil it takes. Would any of you legends know?
1 answer
10w40 of any brand will do, does not need any special oil, just as long as it has oil, if it is using oil try a slightly heavier oil, say 20w50

Hi guys, i have a 94 mitsubishi express , that keeps blowing the indicator fuse, every time i replace it it works for a while then blows again,the fuel gauge and temp gauge go as well, but work again when i replace the fuse , the hazards work regardless ruling out the blinker module and all globes are fine. Any help would be appreciated as its doing my head in, it just started doing it all of a sudden, and i have not done any recent work on it or messed with any wiring. Any suggestions, please?
1 answer
Usually caused by wire chaffing behind the speedo. There are a couple of metal brackets that hold the instrument cluster that the indicator wires pass over en route to the hazard light switch. Hazard lights are just an extension of the indicator circuit. Where the wires to the hazard switch pass across the sharp edges of the metal brackets that support the instrument cluster the wires have a reputation for chaffing and short out. It will start doing it as you pass over bumps at first. Remove the cowling from around instrument cluster and attempt to locate the short circuit. Wrap wiring loom in electrical tape. My dinner plate size hands had trouble accessing it through the aperture even after removing cowling and instrument panel so I had to resort to option B). This was after passing over $500 for an auto electrician who failed to fix it properly. Option B) remove steering wheel and dash and retape all the wiring loom across the front of the van. Sounds worse than what it actually is and the whole lot just snaps together when reassembling. I was pleasantly suprised how quickly it all went back together. Soldered up some wires for audio connections whilst I was at it. Intermittent connections on speakers had been bugging me for a while so fixed both issues at the same time. Check other posts on how to remove dash as this was covered in detail.

Page 5 of 12

Get an answer from our members and Mitsubishi representatives

Similar listings