??!
4 photos
Philips AquaTrio Pro FC7088/01

Philips AquaTrio Pro FC7088/01

2.2 from 12 reviews

Reviews

2.2

12 reviews
5
(1)
4
(2)
3
(1)
2
(2)
1
(6)
    Previous
    Next

    Disappointing!

    published
    Date PurchasedMar 2014
    3 comments
    Philips
    Philips S.Philips
    Wendy G
    Wendy G
    Philips
    Philips S.Philips

    We're sorry to hear this, Wendy. You can always send us a message on Facebook or Twitter for further assistance. We like to have another look at this and see if we can help you.

    Kind regards,
    The Philips Australia Team

    TTran

    TTran

    • 2 reviews

    Poor Philips Customer Service-Faulty AquaTrio Pro mop

    published
    Date PurchasedMar 2016
    3 comments
    Philips
    Philips S.Philips
    TTran
    TTran
    Philips
    Philips S.Philips

    Philips AquaTrio Pro FC7088/01

    published

    The device broke down several times within less than a year, last time the floor horizontal part broke off the vertical part, it turned out that the joint subjected to significant mechanical stress was wade of about 1mm thin plastic. The design is made by an idiot. It is an expensive garbage, and it ended where it belongs. It seems like pretty much all products of Philips are of similar grade. I would like to give it a 0 star grade if it was possible.

    Date PurchasedMar 2015
    1 comment
    Philips
    Philips S.Philips
    Steam Mops

    Find out how Philips AquaTrio Pro FC7088/01 compares to other Steam Mops

    Know better, choose better.

    Compare all

    Great idea - pity the product doesn't live up to the hype

    published
    Date PurchasedOct 2016
    3 comments
    Philips
    Philips S.Philips
    KLD
    KLD
    Philips
    Philips S.Philips

    I love this product

    published
    1 comment
    Philips
    Philips S.Philips

    Haven't actually used it yet

    published

    I received my new appliance. Excitedly unpacked it, only to discover it cut off constantly. Checked water levels, trouble shooting, stood it upright, took the handle out, reattached it. Then I pressed the 'on' button in without the handle attached and it continued to run. Obviously this won't be sufficient without a handle. There must be a fault within the operation handle. TVSN offered a refund or replacement. I choose a replacement, but now I'm thinking I should have just taken a refund after reading all these reviews! Oh dear!!

    9 comments
    Philips
    Philips S.Philips
    Deb
    Deb
    Philips
    Philips S.Philips

    The Aqua Trio may need to be primed. Leave the Aqua Trio upright and stationary and holding the trigger for 15 seconds. This will remove any air or bubbles from the system. Repeat this step if the problem continues.

    Soo

    SooCairns

    Very disappointed

    published

    I was so excited to purchase and receive the Aqua trio. I had problems a couple of months in with the water container leaking. Returned it to TVSN - waited nearly 3 months for a response - was told they would follow up with Philips. I came home and new water containers received from Philips - had to then ring to see where rest of machine was. It eventually arrived. Re assembled and won't work - blue light on but no rotating of rollers or power.
    Will contact TVSN again to return - don't want it - don't trust it to be reliable - not cheap and expected much more.

    2 comments
    Philips
    Philips S.Philips
    Philips
    Philips S.Philips

    We forgot to mention that if you prefer to be contacted, you can share your contact details with us through a private message here. We'll make sure they'll reach out to you. :)

    Kind regards,
    the Philips Australia team.

    Laura Landini

    Laura LandiniSydney

    • 4 reviews
    • 7 likes

    It's wonderful.

    published

    I have verified 600x600 and I use to have to vacuum, mop and if I didn't want to see the streaks on my floor, I had to dry them as well. For the people complaining that the powers cuts off.. it because the water tank is low.. just add some water, and if will be ok.. I'm ecstatic.. love it.

    2 comments
    Philips
    Philips S.Philips
    Laura Landini
    Laura Landini

    Thank you,

    very good

    published

    I bought aqua trio 2 months ago and my mom too. Mine works just fine, i am really satisfied with it. No stains and floor dries really quickly. But the one my mom bought, the container of clean water started leaking with no reason why. Everything looks just fine.
    All in all - It is easy to maneuver but it doesnt celan edges, i have 170m2 to clean and i fill tank 4-5 times. i clean it everytime im done with it and i use it at least 4times a month.

    3 comments
    Philips
    Philips S.Philips
    Tina
    Tina

    Despite leaking water container mom is more than satisfied. She has a dog in house and she doesnt have to vacume and clean floors seperatly.

    Philips
    Philips S.Philips

    That's good news Tina! Should she ever want to get in touch with us regarding her AquaTrio, she's more than welcome to reach out to us. :)

    Kind regards,
    The Philips Australia Team

    Steam Mops

    Find out how Philips AquaTrio Pro FC7088/01 compares to other Steam Mops

    Know better, choose better.

    Compare all

    Love and hate!

    published
    1 comment
    Philips
    PhilipsPhilips
    Sandra56

    Sandra56South East Queensland, QLD

    • 44 reviews

    Not great

    published

    I have used this item twice. First time on 5 separate occasions it asked me to clean the rollers over the space of 10 minutes. Also when tried to use the cleaning tray it did not remove the water there as it did not go for the required time ie 15 seconds, so dripping dirty water onto the cleaned region. It actually cleaned quite well and dried quickly, but the appliance is a nightmare to use for anything taking more than 20 minutes. Changing the water was not an issue only needed to do that twice. Wish I had some the other review before buying the product have returned it.

    1 comment
    Philips
    Philips S.Philips

    Hello Sandra. We're sorry to hear that the product didn't meet up to your expectations. Please call us on 1300 363 391. We’d like to get in touch and see if we can help you.

    LFH

    LFHNSW

    Very disappointing

    published
    1 comment
    Philips
    Philips S.Philips

    Hello, sorry to hear about the difficulties you’ve experienced. Please call us on 1300 363 391. We’d like to get in touch and see if we can help you.

    Questions & Answers

    Lukas B.

    Lukas B.asked

    hi all, the issue i have with my machine is that the brushes are rotating normally (they are not wet, but dry, also pretty new), but the water from the water tank is not running down to the brushes. I even tried putting to descale with a softener agent, but that didn't result in any difference. does someone have any other things i can try? thanks!

    3 answers
    Philips
    Philips S.Philips

    Hi Lukas, thank you for flagging the issue you're facing with (the water tank of) your AquaTrio Pro. Our product specialists would be happy to investigate this further, to see how they can help, so we'd recommend you to contact them at 1300 363 391 (Australia) or 0800 658 224 (New Zealand). We hope that you can use your device without issues again soon. Wishing you a nice rest of the week.

    Kind regards,
    The Philips Australia Team

    Lukas B.
    Lukas B.

    Hi Philips team, thank you so much for your reply - much appreciated!

    I solved the problem by gradually adding water to the floor, and using the brushes to go over it...and after couple of minutes, the water also started flowing again from the water tank so solved!

    Best, Lukas

    Philips
    Philips S.Philips

    Hi Lukas, great to hear that the problem is solved. If you have any questions feel free to contact us!

    Peter R.

    Peter R.asked

    I have problem with my Philips AquaTrio Pro when I vaccum like 15 minutes stops working and start flashing
    green and red green and red light and i dont know what to do.
    here is my youtube video that I record. Any help?

    https://www.youtube.com/watch?v=SamvFggQc8E

    2 answers
    TTran
    TTran

    Hi,
    I do not have this machine anymore but if you open the lid- check brushes are clear and cleaned. If the brushes are really old change them?
    Make sure all parts are connected in properly and lid closed.
    Hope this help!

    Philips
    Philips S.Philips

    Hi there, Peter. Thanks for getting in touch. In this case we think it's best to contact our product experts directly via the below link:

    https://www.philips.com.au/c-w/support-home/support-contact-page.html#n62Contact=HOUSEHOLD_PRODUCTS_GR%2BVACUUM_CLEANERS_CA

    They should be able to assist you further. Kind regards, The Philips Australia Team

    JURSKI

    JURSKIasked

    hello,

    recently i mopped a severely dirty balcony floor and some small stone particle was mopped also. Then the machine only starts to work 3 seconds and red light appears on brushes and the machine goes off. Every time i turn it on, it repeats the same, 3sec and off. What could i do to fix it, which part to open and clean maybe? The machine is great so i would like to make it work as soon as possible.

    Guarantee is off so i would like to try to do something by myself. Any suggestions?

    best regards,

    Jura, Croatia

    4 answers
    TTran
    TTran

    If red light flashing- lid not closed properly.
    If red light static- remove roller and unblock and clean out. Close lid.
    Hope this help.

    Philips
    Philips S.Philips

    Hi Jura. Thanks for reaching out. We're sorry to hear that you're AquaTrio seems to be malfunctioning. Hopefully we can how out. Could you try the following tips to remove the stone? https://www.philips.com.au/c-f/XC000002505/my-philips-aquatrio-pro-shows-a-red-light-during-flushing. This should get it working again, but if it doesn't we recommend reaching out to us via Facebook or Twitter(@PhilipsCare). We'd be happy to help figure out how to get your AquaTrio up and running again.

    Kind regards,
    The Philips Australia Team

    JURSKI
    JURSKI

    Hello, I've tried this method but something else is on here. I've noticed that the rotating particles on which brushes are attached have a slight left-right motion, well at least one of them, other one is firm and not being able to rotate a bit. Maybe something stuck in the housing preventing brushes to rotate, when i turn it on, it Works few seconds but i can see below that brushes don't start to rotate. Any hints?

    best regards

    Get an answer from our members and Philips representatives

    ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.