??!
2 photos
Samsung Powerbot VR9300 (SR20K9350WK)

Samsung Powerbot VR9300 (SR20K9350WK) Questions & Answers

MPN: SR20K9350WK
2.7 from 17 reviews

6 questions from our users

Yosen Y.

Yosen Y.asked

Powerbot VR9300 (SR20K9350WK)

can the firmware be upgraded? if yes, how to do it?

1 answer
Samsung
JoanneSamsung

Hi Yosen, when the power is supplied and your POWERbot is docked on the docking station, the POWERbot
will be connected to the server and then check if there is software updates. If there is the latest
software, it will be automatically downloaded and updated.

If UP is displayed on the display panel while the POWERbot is charging, it means that the update
is in progress. Please wait for unit to complete the rebooting.

User Manual (page 22) > https://www.samsung.com/au/support/model/VR20K9350WK/SA/

Jo
Samsung AU


anne castle

anne castleasked

Powerbot VR9300 (SR20K9350WK)

Why is my powerbot cleaner only working for about 30 mins then says battery lo , it can't find it's way to charge station, it's hasn't been moved, had this about 18 months now, also it never cleans to edges

2 answers
Tony
Tony

I have a similar issue and mine is only about 6 months old .

Samsung
Samsung AUSamsung

Hi Anne, this sounds like something our Support Team can assist you with. We recommend for you to contact 1300 362 603 so that we can look into this for you.

Jo
Samsung AU


Deirdre

Deirdreasked

Powerbot VR9300 (SR20K9350WK)

I have had my powerbot for about 4 months (SR2AK9350WK)
Last night it simply lost all suction, so it is riding around but not working. Also, when it starts it makes a sort of grinding noise. I have cleaned everything that it is possible to clean, and it is fully charged. Help?!

1 answer
Samsung
PhilSamsung

Hi there, it sounds like there may be an issue with your PowerBot that needs to be looked at by a technician. Please follow the link provided so that you can locate your nearest service centre for a visit, and our friendly techs can assist you further!

https://www.samsung.com/au/support/service-centre/

Philip
Samsung Australia


Chris

Chrisasked

Powerbot VR9300 (SR20K9350WK)

C1 error code comes up aftet 10 seconds. Brand new and have taken the brush out 5 times and cleaned though already clean as first time using and code still comes up. Any ideas?

1 answer
Wayne D
Wayne D

I had the same problem, what I found is there is a circuit board on top of the brush, when I took that out I could see components that burned up. I order a used replacement board and put it in and that fixed the problem.


Jimmykw

Jimmykwasked

Powerbot VR9300 (SR20K9350WK)

my vacc can not find home dock even when right in front of it with power on, any help?

1 answer
Juis Vergara
Juis Vergara

It might be because you lifted or moved it while it was operating, that kind of confuses it and can't find its way back to the charging dock.


adrigeddon

adrigeddonasked

Powerbot VR9300 (SR20K9350WK)

I think that my vacuum has aspired water, and now it starts well( all the lights, wifi, conections etc.. it is full of charge ), but when it try to start de engine ( play button ), it turn off. I cant bring it to a service , becouse now i am living in Argentina. What can i do? any possible solution?

2 answers
Tony Hynes
Tony Hynes

My solution would be to find a second hand shop and pass your troubles to someone else
Samsung will be no help!

Tony Hynes
Tony Hynes

My solution would be to find a second hand shop and pass your troubles to someone else
Samsung will be no help!


See all Samsung Powerbot 9000 Series questions

Get an answer from our members and Samsung representatives

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.