??!
7 photos
Samsung Powerbot 9000 Series

Samsung Powerbot 9000 Series Questions & Answers

VR9000 (SR20H9050U), VR9200 (SR20J9250U) and VR9300 (SR20K9350WK)
3.7 from 75 reviews

65 questions from our users

Why is my powerbot cleaner only working for about 30 mins then says battery lo , it can't find it's way to charge station, it's hasn't been moved, had this about 18 months now, also it never cleans to edges
2 answers
I have a similar issue and mine is only about 6 months old .Hi Anne, this sounds like something our Support Team can assist you with. We recommend for you to contact 1300 362 603 so that we can look into this for you. Jo Samsung AU

Hi , can I create 2 maps of my house eg front part of the house , then do a back part of the house . I’ve tried a few times to map my entire house but the battery never goes the full length and as such it doesn’t map anything . Any ideas would be appreciated. Thank you
No answers

Question was asked last year with no replies by someone else. Powerbot is displaying mute and error triangle. Will not start. Tried turning off and on the master switch and powerbot displays these 2 icons while system check is performed. Any help would be greatly appreciated. I have even pulled the battery ,and let sit overnight to see if that worked with no positive results.
1 answer
Hi there, we're sorry to hear you are experiencing these issues. This will be best to get looked at by our technicians at your nearest service centre. Please follow this link in to locate your nearest Samsung approved service centre: https://www.samsung.com/au/support/service-centre/

I have had my powerbot for about 4 months (SR2AK9350WK) Last night it simply lost all suction, so it is riding around but not working. Also, when it starts it makes a sort of grinding noise. I have cleaned everything that it is possible to clean, and it is fully charged. Help?!
1 answer
Hi there, it sounds like there may be an issue with your PowerBot that needs to be looked at by a technician. Please follow the link provided so that you can locate your nearest service centre for a visit, and our friendly techs can assist you further! https://www.samsung.com/au/support/service-centre/ Philip Samsung Australia

Hi, I have the Samsung 9000 series (SR20J9250U) and for the past 2 months it will turn itself off when vacuuming and also when charging. I have to reboot it but sometimes will not turn back on for hours. I had it on charge the other night and did not charge at all. I cannot use it and have to use my Dyson. Will this be covered under warranty?
1 answer
Hi there Kim, it sounds like you may have a fault with your Powerbot. I suggest you head into your nearest Samsung service centre with the Powerbot and get one of our technicians to assess your unit. Here are a few links which can help you get to where you need to go: Store locator: https://www.samsung.com/au/support/service-centre/ Studio bookings: https://www.samsung.com/au/samsungstore/bookings/#/ Self Service AusPost: http://samsungcare2.samsungcsportal.com:81/samsungcare/au/index_m Customer care line: 1300 362 603 Philip Samsung Australia

I've had our powerbot for about three years (SR2AK9350WK). It will charge when docked with the remote but when I press start it backs up off the dock about an inch and stop. If I manually try to press buttons nothing happens and if I use the remote to get it to re-dock nothing happens. Any ideas?
1 answer
Hi there, sounds like your PowerBot may have a fault! It's okay, our technicians can look into this for you. Please visit your nearest service centre with the PowerBot for assistance. Here is a link to find your nearest: https://www.samsung.com/au/support/service-centre/ Bookings https://www.samsung.com/au/samsungstore/bookings/#/ Philip Samsung Australia

I have changed the location of the docking station but the Powerbot only goes back to the old location. Any tips?
2 answers
Hi there, you can either go into the Smart Things app, and reconnect the device, if this method does not work, we can get our L2 techs to contact you to run troubleshooting for the unit. You can either reach out to us via Facebook, Twitter or email us on reviews@samsung.com Phil Samsung AustraliaThank you it fixed itself. no more problem. It's works great., I love it

Anyone have an issue with their vacuum not being able to vacuum an area rug? I have owned this vacuum for about a year. I have never had an issue with it transitioning from carpet to tile or hardwood. I bought an area rug and now it won't go over it. I either wanted $300 on this rug or $700 on the vacuum. Anyone have any ideas?
1 answer
Depending on thick the rug material is, the Powerbot is generally designed to go over floor surfaces such as carpet, tile or timberfloors, unfortunately as rugs are an external surface, the Powerbot may struggle, especially if the rug has a thick surface on top. It would be recommended that you manually clean the rug surface.

I have a 9000 series cyclone and all of the sudden after 11 months when you press button to clean it backs up a half inch and stops and acts as if battery is dead I have to reboot vacuum to get it to charge but it will not vacuum. Any ideas?
2 answers
That's strange, Lee. Have you had the chance to get this checked out by a technician? If you send us a message on Facebook/Twitter with your suburb and postcode, I will be able to locate your nearest service centre for you, alternatively you can contact our support line on > 1300 362 603 Sara Samsung AustraliaHi Lee, I'm having a similar issue after 2 years of faultless operation. No actual error code, just backs up, wiggles around a bit and the exclamation symbol lights up. No resoloution with reset and full clean. Was your issue solved? Thanks in advance, Rachel

My Samsung robot SR2AJ9040W brush does not spin. Brush is clean and nothing stuck on it vacuum runs has suction but brush does not turn. Any ideas?
1 answer
That doesn't seem right Linda, let's get this looked at by one of our authorised technicians. If you click on the below link you can locate your nearest service centre, they will be able to try some troubleshooting steps with you first hand and have this resolved in no time. > https://www.samsung.com/au/support/service-centre/ We do hope this is resolved for you very soon. Jazz Samsung Australia

Our powerbot was great for the first 2 months! We've had over a year now. Can hardly stand using it cause it is noisy! We've cleaned everything and it sounds sick! I want some help and feedback! Any ideas?
No answers

I have a 9020...it's been acting erratically, like it thinks everything is a ledge it might drive off. I was wondering if there was any way to replace the cliff sensors?
No answers

I have a question about my Samsung robot vacuum It’s making a noise and I have checked all the simple things but was wondering if there could be something in the motor that I can’t see.
2 answers
Mine make a noise when I put it in the maximum vacuuming power but I usually select the first (minimum power) which is almost quite because I use it 3 times a week so I don't need a maximum vacuuming power, I agree this model is more noisy compared to other brands or cheaper ones in Samsung, but you need to consider that this model is the most powerful robot in the market so far, (in terms of suction systems)Mine make a noise when I put it in the maximum vacuuming power but I usually select the first (minimum power) which is almost quite because I use it 3 times a week so I don't need a maximum vacuuming, I agree this model is more noisy compared to other brands or cheaper ones in Samsung, but you need to consider that this model is the most powerful robot in the market so far, (in terms of suction systems)

C1 error code comes up aftet 10 seconds. Brand new and have taken the brush out 5 times and cleaned though already clean as first time using and code still comes up. Any ideas?
1 answer
I had the same problem, what I found is there is a circuit board on top of the brush, when I took that out I could see components that burned up. I order a used replacement board and put it in and that fixed the problem.

I have a samsung SR1AM70 and it was cleaning and then the motor stopped working but the power it kept moving. I pushed the home button and it returned to the dock. I turned it off and on but it still just moves but the motor does not come on. Any ideas?
No answers

Hey, i have the Samsung Powerbot VR9200 VR20J9250UK/SA - i put it on the base and it says "FULL" but then once i click the start button for it to clean it will dismount off the charging station, turn around and then turn itself off and the screen goes black - i then have to turn the emergency switch off underneath the unit and back on and the screen will come back on and do its count down from 5 then go back to the normal screen, once i click start again it does the same and will not work. I have tried cleaning all sensors best i can but due to the fact it doesn't come up with a sensor error message i gather its losing signal or battery. After charging battery for hours i removed and tested with a multi meter and was reading 23.2V and the battery is a 21.6V so i gather the battery is good condition and holding charge.. is there any other tips or things to try? Thanks in advance for your help
2 answers
I'm having the exact same issue. Did you get any answers?Same here! I am about to return it.

I have a POWERbot model # SR2AJ9020 U Series and I can't turn off the Auto function. It just takes off all on its own. I want to manually function this machine only. How do you turn off the auto function?
No answers

Why would my Samsung 7090 have no suction and now it turns off by itself and won't do anything?
No answers

Where can I download the user manual please?
No answers

Page 1 of 4

Get an answer from our members and Samsung representatives

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.