4SsangYong Rexton Y200 / Y220
Part of SsangYong Rexton 3.8 

SsangYong Rexton Y200 / Y220 (2003-2006) Questions & Answers (page 7)

 Verified
George Barry
George Barry · Rexton Y200 / Y220 (2003-2006)

I have just bought a Rexton 2005 but it has only done 118000 K's I just put 2 new tyres on the front and only drove about 50 k's and it felt like the drive chain was binding I had an automatic gearbox guy look at the transfer box there was a bit of wear on 2 bearings so he replaced them I have since put 2 more new tyres on in a straight line alls okay but soon as I go to turn something start to bind and feels like there is slippage.The noise appears to be behind the driver. Anyone had anything similar to this? Regards George

Greggie-e
Greggie-e  

Hi, I had the same problem, we put a new set of tyres on the rear, different brand to the front. Although they say they are the same size there was a slight difference. This caused the front to run at a different speed to the rear which in turn kept winding up the transfer case. eventually the transfer case blew. Make sure the tyres you use are same all the way around!

Andy bibs
Andy bibs  

I have a similar problem on my 06 SX 270 front diff seized up replaced it was fine for 3 months changed the front tyres was still ok then went on a long trip coming home it started to make a thump thump only at high speed 70 mph +. Off with the diff no cogs broken replaced a bearing and seal also the cv shafts. Drives great until you put your foot down thumping noise again only when you step on the gas though, tried it on on low ratio drives ok in a straight line turn the wheels to full lock left or right. Thump thump? I am off to swap the tyres round see if that works but sounds like my transfer case is going!!

Andy bibs
Andy bibs  

Andy bibbs,Wigan, England just swapped my tyres round hey presto no more thump thump. Thank god and thank you for your reviews was about to strip the transfer box down!!

Moses N.
Moses N.  

To stop slippage new tyres must be fixed at the rear instead of the front.

Morne love
Morne love · Rexton Y200 / Y220 (2003-2006)

I am in South Africa and found a Rexton RX 320 2005 model for a great price and in brilliant condition. I have read the stats and noticed that the fuel consumption is around 19l to 100km, but I noted that Rexton owners have a different figure. One gentleman stated he is getting 8l to a 100km. Can someone please give me the correct figures before I go out and buy it? In 2 minds due to the factory specs. 19l to 100km seems a bit off.

Musso-rific
Musso-rific  

You can expect 13 to 14 average. The petrol ones are a lot thirstier than the diesel ones, but the engine is mercedes, so it is at least durable and quite powerful.

KirinRulz
KirinRulz · Rexton Y200 / Y220 (2003-2006)

What can I say.

my beautiful lemon is playing up again.

2004 ssangyong rexton, the battery died. Needed to get jump started when transported to another state. When I picked it up, engine light came on and disappeared. With temperature showing Hot. This happend first 3 days. On n off.

2 days it drove well. Temperature gage at middle but engine light came on twice, when at red light n disappeared when took off.

Now lost rev, speed, gear, fuel, temperature. All not working. And now engine light is back on.

Any suggestions what is going on?

SMC

(Savemycar)

Lol

Musso-rific
Musso-rific  

It needs to go on an engine scanner to look for fault codes - go to a Ssangyong dealer as the OBD scanners that most garages have may not read it properly - it is far from unheard of that people plug into a non Ssangyong scanner and getting a rubbish reading that is unhelpful.

The most likely causes of your woes are either the viscous fan needing replacement (on older high km cars) or a faulty temperature gauge sender. The engine light coming on is the system warning you it is getting overloaded with fault codes (which it logs to report to the scanner) the loss of revs is it going into limp mode because of the fault the engine management computer picks up. It is a 'safe' mode that protects the engine from causing major mechanical damage to itself. And yes the car will behave like it has absolutely no power - safe mode is really only for driving it off the road out of danger or on to a tow truck etc.

KirinRulz
KirinRulz  

Musso-rific..

Thanks for the reply.

I had it checked out by an 'auto electrician'..

Having all indicators on dash board was not working (dead).

They asked if the dash unit was removed.

I didn't know if it was.

Anyway the dash board wasn't put back in place correctly and the pins got bent.

Once fixed it worked. All indicators on dash working. N beautiful engine light on again. A few seconds, then it disappears.

Okay now its just temperature gage just shoots up past the hot and engine light on.

Pull over turn it off. Wait... turn it on has gone to half or thre/qarter. It stays at qarter or the gage goes back up past hot. Engine light on. After stopping it second time. It stays at three/qarters.

Ok. This happens after 20minutes of driving. Or if I take off from a complete stop. But temperature age goes back down half way.

Could something be up its sensor wiring. ?

Or my dash board needs to get replaced?

(As I was told that it may if it starts playing up)

I strongly belive its not my engine or radiator.

I just had it serviced. Engine oil n filter etc.

It drives well. On highway really good. Take off is slow...thou...

During when this happens tempertaure needle goes up n down with engine light on n off.

Always something different. Lol

And what scaner (name) does one need for a car that is older/younger then 2007. As my obd scaner doesn't work with my cars...

As ther are 2003 outlander and

2004 Rexton diesel.

Thanks in advance...

KirinRulz

Sorry it's long read...

Eric Esrada
Eric Esrada · Rexton Y200 / Y220 (2003-2006)

My rexton is a 2.7 diesel turbo. I found that there is a problem when i driving i noticed that the temperature gauge suddenly drop and not function. at the same time i also noticed that my air con compressor not working as well.

While i keep on driving the temperature gauge and aircon compressor resume at working condition.

Appreciated if someone could advice me and solve the problem? best regards

brian
brian  

It's probably better to take the vehicle to a ssang Yong Australia workshop or a auto electrician shop might be able to help

Ken Smith
Ken Smith  

Hi,

I think I can help....

I also have a 2005 Rexton that had the same problem at 150,000KM. The temperature gauge went to full scale deflection (way past hot) and the engine check light came on. No one in this area has the special tool to check fault codes, so I had to methodically check each item to find the problem. Sometime the vehicle was also impossible to start.

What I found is that the Engine Power Relay had failed and after installing a new Engine Power Relay the problem was fixed.

The Engine Power Relay can be found in the relay box in the engine bay. The markings in the relay box lid will show you which relay you need to replace.

If you choose to use a non-genuine relay, be sure to get a very good quality one. The first one I installed was a cheap Chinese job that was also burned out in a few days...... The genuine item is the way to go.

AaJjSs81
AaJjSs81  

I had the same problem for ages, trust me it will happen more afton the longer you leave it. Researched this problem for ages and found someone from Bosnia that suggested changing the thermostat. Bought the part from ebay ($80) swapped it out, no problems since.

Rita Rich
Rita Rich · Rexton Y200 / Y220 (2003-2006)

We have a 2005 Rexton. Traveling down hwy check light came on & temp gauge went up to hot. Pulled over car was not over heating. Sat for awhile then turned around to come home temp gauge stayed on just over 1/2 way & check light went off. Drove 200 km & car never missed a beat. Ssangyong dealer said it needs to go on computer as there has to be a problem. When we got home trurned off then started again all back to normal. Has anyone else had a problem like this?

Rexton guy
Rexton guy  

Yep. Exactly the same problem. Had happened 9 or 10 times over the last few years. Mine is 2006 model. It appears to be an electrical sensor issue and corrects itself or I just get the mechanic to reset the codes.

Rita Rich
Rita Rich  

We had Ssangyong replace the temp sensor as that is what the code came up. 5days later temp gauge went up again so we took it back to Ssanyong & they reset the sensor & took it for a long drive. We will keep our fingers crossed that is the end of it. Thanks for your reply.

Musso-rific
Musso-rific  

No, never had that issue before, but given that your car is now coming up 10 years old, corrosion can affect the odd electrical circuit here and there on any vehicle. If it happens again, I'd check the physical connection on the engine block and clean it.

Ken Smith
Ken Smith  

Replace the engine power relay and I am sure that your problem will be fixed. My 2005 2.7 Rexton did exactly the same thing and the relay was the cause.

The engine power relay is found at the relay box in the engine compartment. A cheap 40A relay from the Auto Electric shop will get you going, but will also fail after a month or two. The genuine part will last for years.

Andy
Andy  

Take a battery terminal off and on again , it resets the computer and that's for most things on ssangyoung simple but effective mechanics won't tell you

Rita Rich
Rita Rich  

Thanks Andy

My husband loves his car. Very comfortable to drive. This problem just gets to you. We have replaced the relay, temp sensor. Ssanyong have reset it several times. We had a auto electrician spend a day looking it over & he can't find the problem.

kim
kim · Rexton Y200 / Y220 (2003-2006)

Can u fit a after market petrol pump and filter in a rexton?

Wes
Wes  

Yes you can Kim

Kim
Kim · Rexton Y200 / Y220 (2003-2006)

I have a REXTON 2005 model and have a problem with my water separator light coming on and shutting the car down. I have just had fuel and separator filters changed and still having the same problem. Any suggestions please??

hard worker
hard worker  

Been there, done that. It's the sensor, not the filter. Seems that at a certain age, once the sensor has discovered water in the fuel once, it gets all excited and keeps tripping even after the filters are changed. I have this lovely Ssangyong service guy in Hornsby in Sydney who sees enough to them to have detected this (hell, if this is the biggest problem we have with ageing "Rex"s, then we don't have a problem!). He changed my sensor and "bing"! no more problems! :)

brian
brian  

If there is no problem with a gasket then I would have to agree with the other answer as it's likely to be the computer or a sensor problem

Alice
Alice · Rexton Y200 / Y220 (2003-2006)

My rexton car got hit by another vehicle at the driver side. After the incident , the car stops on its own . What is wrong with it?

hard worker
hard worker  

Something in the electronics has either been directly hit, or has been put out/broken by the shock of the impact. Talk to your Rexton person about the computer....

brian
brian  

I basically agree with the other answer / it's best to take the vehicle to a ssang Yong Australia workshop or a auto electrician shop might be able to help or it could have suffered a shock somewhere else in which case a different mechanical repairs workshop if the other 2 options fail might be able to help

sandra
sandra · Rexton Y200 / Y220 (2003-2006)

4wd check light comes on goes into low range the only way to clear it is to turn the car off wait and then turned it back on . no one can find out why please has someone got any ideas

buster
buster  

Same thing has happened to me4wd it clicks into when I reverse.Is it a auto hub or manual hub?Ssangyang Rexton 2005 manual 4wd turbo 7 seater.I will try turning it the car off and see if it clicks back to normal.Can anybody help.Big Thanks.

Robyn
Robyn  

Apparently you need to go in 4wd mode at least once a month even just back and forth on driveway. My lemon of a car often had HDC and or 4wd light come on and apparently this will stop it happening

Cookie70
Cookie70 · Rexton Y200 / Y220 (2003-2006)

I have a 2004 Rexton 2.7 auto diesel was ok for 6 months however am now experiencing a lack of power through the throttle especially from a standing start it has a 3/4 second delay before power comes through which is a problem at roundabouts etc. It is fine if I use tiptronic gears which sends the revs up. My mechanic has had it on a diagnostic machine which shows no faults. Help please

HARRY B68
HARRY B68  

Sounds like there is a lot of turbo lag. The diagnostic machine may not pick up the fault. Ask your mechanic to test the turbo vacuum solenoids.

Graham8032
Graham8032 · Rexton Y200 / Y220 (2003-2006)

My 2005 rexton has suddenly decided to drop into 4xwheel low. Sometimes I can Change it by turning off the engine then restarting. Recently no luck Had it to the dealer, thought it might have been drive motor to the gears, pulled it appart, went like normal for 5 days then same problem.Love my Rexton and its fuel economy but would like to know if anyone else has had similar problems

Neil Parsons
Neil Parsons  

I have not had that problem .Not to sure but it may be a faulty switch or a short somewhere .

Graham8032
Graham8032  

Ta, for suggestion...am looking at wire harness at moment and giving it a week's trial. Penrith Sangyoung have been very good.

HARRY B68
HARRY B68  

Haven't encountered anything like this. My mate has just had the transfer case rebuilt on his as the oil hadn't been changed from new. He tells me there are a lot of electronic components attached to the transmission. This could be cause of your problem.

BIGH18
BIGH18  

my car is having the same problem mechanics seem to think it is the trans after two days in the shop withy no results. Have you found out what was the problem as you know it is fustrating and could be costly for me. could use your assistance...

sandra
sandra  

my car is doing exactly the same and no one knows how to fix it??

Brian58
Brian58 · Rexton Y200 / Y220 (2003-2006)

We are buying a 2005 Diesel Rexton, when test driving the vehicle I noticed that the temperature gauge started rising quickly, I pulled to the road side to investigate, the gauge stayed on the 3/4 mark, I lifted the bonnet to assess, 1) The engine was not over heated, 2) The water header tank had pressure, the water in it wasn't boiling. I waited for 10- 15 minutes, looked at the temp gauge the needle was on now the quarter mark, turned the key on & proceeded on my journey, this time the gauge went to the Red mark, once again did the same routine as before, engine was no hotter.

Took the vehicle back to the agent I told them what happened, the service manager said that takes the total to 6 with the same problem, they haven't found a remedy after changing gauges sender units etc, they seem to think that it relates to Ohm resistance between the gauge & the ECU could this be so? has this happened to another owner? Appreciate a remedy. Best regards Brian

annynrok
annynrok  

Dear Brian

I have only had a couple of instances when the temp gauge has shown HIGH & it went away as soon as I stopped to see what the problem might have been. The service guys at Northern Ssangyong in Victoria who we speak with if wanting parts or advice say it is probably a sensor rather than thermostat. We haven't done anything about it yet but will try replacing the sensor if it hapens more often. They also said if when you stop & turn engine off & the gauge returns to normal its a sensor, if it stays high then it may be thermostat or something else.

My car is coming up 7yrs old & 95000km with no real problems but I have had it since new & altho tow a double horse float regularly, try to treat it nice.

I probably wouldn't go ahead with purchase if this problem occurred when test driving.....

Andy
Andy  

Take terminal off battery it resets computer

jocon888
jocon888 · Rexton Y200 / Y220 (2003-2006)

Other than SSangYong are there any reputable mechanics who can service and repair my 2005 Rexton RX320 Joe Mitcham

annynrok
annynrok  

My Rex is a 2.7 Diesel so only really needs fuel & oil filters done regularly. We mostly do our own basic servicing & purchase filters etc from Northern Ssangyong in Victoria. They seem very helpful & parts are reasonably priced. They have an ebay store too. More major services we have had done at Power Torque Transmissions in Oak Flats NSW, but have specified exactly what is to be done & don't get any additives & minimum charges for labour etc that all make for extra cost.

Did buy a CD online too that is a workshop manual of sorts which is helpful if mechanically inclined.

Good luck, hope your Rex is going well for you.

jocon888
jocon888  

Thanks for your kind assistance. If you can point me in the right direction regarding the service cd, it would be appreciated,

Regards,

Joe

rickpeppy
rickpeppy  

Look on ebay,type what you want,plenty to choose from!!!!

Get an answer from our members and SsangYong representatives

Select a listing for your question
SsangYong Rexton Y200 / Y220 (2003-2006)

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.

©  ProductReview.com.au Pty. Ltd. All Rights Reserved. General disclaimer: All third party trademarks, images and copyrights on this page are used for the purpose of comparative advertising, criticism or review. This is a public forum presenting user opinions on selected products and businesses, and as such the views expressed do not reflect the opinion of ProductReview.com.au. Further details in the disclaimer.