??!
3 photos
Sunbeam Torino Espresso Machine & Grinder PU8000

Sunbeam Torino Espresso Machine & Grinder PU8000 Questions & Answers (page 2 of 2)

MPN: SNB-PU8000
2.7 from 39 reviews

34 questions from our users

Lauren E.

Lauren E.asked

My machine won’t turn on at all. No lights nothing. Checked power point with other devices and it works fine... any reset buttons or anything I should try???

2 answers
Brendan
Brendan

I can’t help sorry. We took ours back.

Sunbeam
Customer C.Sunbeam

Hi Lauren E, if there is no power to the unit you will need to call our team on 1300 881 861 for further assistance...

lawrence M.

lawrence M.asked

My Machine is just running water out of the head. the 1cup and 2 cup lights are on. What do i do

2 answers
Sunbeam
Customer C.Sunbeam

Hi lawrence M.
Thank you for contacting Sunbeam. For further assistance please call us on 1300 881 861 and we would love to assist you further.

Annie
Annie

The same is happening with mine. Are there any tips to try as Sunbeam aren't opened on a Saturday unfortunately and people are busy

Terry Mack

Terry Mackasked

I unpacked my Torino Coffee Machine today. It was purchased from Sunbeam Nunawading last Monday. Until now I have had a Sunbeam E Series for more than 10 years.
I cannot get the steam function to work at all. I have looked at all the tutorials, to no avail.
Can you help. It is a 3 hour journey to Nunawading to take it back!
Terry McKiterick, Echuca, Victoria

1 answer
Sunbeam
Customer C.Sunbeam

Hi Terry Mack,
Thank you for your question regarding your Torino. Being a brand new unit - it may need a bit if a jump start. We suggest running the steam pump continually for 3 minutes maximum. if this does not get the steam going please try running the steam for 20 seconds then remove the water tank - while pump still running- for a further 20 seconds. Then replace the water tank with force. This can push through any air blockages and also awaken the valve connecting the tank to the unit. If this does not resolve - please call us on 1300 881 861 and we would love to assist you further.

Ren

Renasked

When machine is turned on in the morning it pours a large amount of water from opening into drip tray. Sometimes it uses almost half the tank of water. Why is this?

1 answer
Sunbeam
Customer C.Sunbeam

Hi Ren,
I would like you to call our team on 1300 881 861 to discuss further

Sophie H.

Sophie H.asked

Hi there,
Just opened my Sunbeam Torino this afternoon and everything works fine but the steam wand. After I do my shot, then go to use the steam wand it doesn’t want to steam? It makes thumbing sound and continuously goes on. How do I fix this problem?

Any ideas?

1 answer
Sunbeam
Customer C.Sunbeam

Please call our team on 1300 881 861 to discuss as soon as you can. Sometimes the steam can take a few minutes to come through but if it's going on, they may need to ascertain if there is something not right.

Shaun W

Shaun Wasked

Hi

We have an ongoing problem where the water comes out around the group head instead of forcing through the coffee (almost like the rubber seal is damaged). If we make grind courser it brews too quickly

Any ideas

1 answer
Sunbeam
Customer C.Sunbeam

Hi Shaun W,
Thank you for your question with your PU8000. Please call Sunbeam on 1300 881 861 and we will be able to assist you further.

Davo

Davoasked

We have had our Torino only about 7 months. It has stopped building up full pressure (only up to 4-5bar) and won't run the complete extraction cycle. I have not altered the grinder setting or other settings on the machine.
It has not been used enough yet to need a clean and the machine is not indicating that it requires cleaning. Any help?
Geoff

3 answers
Susan
Susan

We are having the exact same issue. I have made the grind finer and still pouring out way too fast and at low pressure. Have you found any solutions? Our machine is about 6mths old

Davo
Davo

Hello Susan,
Apologies for the late reply.
My machine is behaving again.
What I did:
1. Checked the grind. It is set on 7 - I have altered it between 6 and 8 as I have searched for the best results.
2. Ran the machine with and without the group several times, with no coffee.
3. Ran the steam pump into a glass jug (so I could see it was working as expected). I found a Sunbeam video explaining how to do this.
4. Ensured that I had loaded sufficient coffee into the group basket. That is, I figured that if I overloaded it (without it actually overflowing), the pressure would exceed the correct range. That would prove to me taht the pressurisation was working, eliminating that as a problem.

As if by magic, the machine has worked fine since then. My Torino and I have been back on speaking terms since then :-).

We have concluded that the machine did not like being left unused for several weeks while we were away. Weird, but similar to the behaviour of a typical teenager (!). Technically, we suspect that there was some sort of partial blockage, even though I flush the steam wand each use and always run clean water through before I turn it off.

If all that does not work, I'm out of answers for you. However, you will have checked the obvious things such as blockages which have interrupted water and steam flow, by giving the thing a thorough flush out.

Good luck.
G

Sunbeam
Customer C.Sunbeam

Hi Davo, great to hear your machine is working fine now. Please keep in mind you can contact us on 1300 881 861 if you require assistance at any time. The Torino comes with a 2 Year warranty.

Rob

Robasked

Why won’t my Torino return to ready after cleaning both cycles twice?

2 answers
Chris
Chris

No idea Rob, I return my machine for a credit.

Sunbeam
Customer C.Sunbeam

Hi Rob,
You may need to give our Customer Service team a call on 1300 881 861 so we can determine exactly what the problem may be.

Ram. Tai

Ram. Taiasked

I did the SO and ST CLEAN 4 times still showing!!
My OCD IS KILLING ME! Any help people pls?

1 answer
Sunbeam
Customer C.Sunbeam

Hi R, this one is a relatively easy fix, is there any chance you can PM your contact number or your email address and we will walk you through the process.

Brotch

Brotchasked

When using the hot water wand the water pulses out rather than as a constant flow. Is this normal?

3 answers
Lucky
Lucky

Hi Brotch. Short answer is yes. All the sunbeams I've owned, the hot water has the pump pulsating process is associated with its use. They are a great machine but do take a little time to refine your techniques to get a great cuppa.
Regards,
Lucky

Brotch
Brotch

Thanks Lucky. Yes I gathered it was a part of the process. Just ensuring the fact as correct. It is a big purchase item for us as we normally use a stove top espresso. So far have been pleased, and now use the manual arm mainly. Brotchie

Sunbeam
Customer C.Sunbeam

Hi Brotch. As Lucky advised, this is completely normal. You will notice that the water pulses in tandem with the water pump.

Brya P

Brya Pasked

I also have just cleaned and descaled EM8000 and it is still telling me to clean it. I have turned it on and off several times with no joy. Does anyone have any suggestions?

2 answers
Sunbeam
Customer C.Sunbeam

Hi Brya. When completing the cleaning cycle did you complete both the CO clean and the ST clean? If these aren't completed one after the other, the machine won't recognise that you have completed it.

Brya P
Brya P

Yes I did both cleans one after the other.

Aileen R

Aileen Rasked

Have just cleaned and descaled EM8000 and it is still telling me to clean it. what have I done wrong? went by the book..

5 answers
Sunbeam
Customer C.Sunbeam

Hi Aileen. Did you complete the ST clean and the CO clean directly after each other? If you don't complete both one after the other, the PCB doesn't register that you have performed the cleaning function.

Aileen R
Aileen R

Yes but I did them in reverse, I cleaned then ST cleaned, waited for one hour and did them again it still comes up CLEAN. I have been in touch with Gemma at Sunbeam who emailed me instructions to help but it is still the same after following her instructions...I replied to her email and am waiting her reply. I am very happy with the machine it makes good coffee so I hope I can fix it.....…...regards Aileen R

jezzp
jezzp

Mine is also doing this. Can Sunbeam please reply with a solution... I did the ST followed by CO clean. Ive also tried to reset the machine back to original settings, still no luck.

Leigh Albrey

Leigh Albreyasked

My coffee machine had the cleaning cycle come up on the display so I put it through both head cleaning and steam cycle but it still comes up with clean. Can you advise me what I need to do?

4 answers
red devil
red devil

unplug machine for a few minutes to reset.

Leigh Albrey
Leigh Albrey

I tried that twice and the cleaning display still caomes up

Hayley L
Hayley L

Any solutions as mine is doing the same

Don

Donasked

Do not know why the its dripping at a very slow rate. Having to press cup2 button to have a decent amount of coffee in the cup. Is it to do with not enough water coming through? Thank you.

2 answers
red devil
red devil

Hi Don have you tried using manual lever, i never use the buttons. also don't tamp coffee too hard.

Sunbeam
Customer C.Sunbeam

Hi Don. If the coffee is dripping out at a very slow rate, this usually means that you are over extracting. Over-extraction generally occurs if your coffee grind is too fine. An easy way to identify this is if your pressure gauge is going right up into the red. Just adjust your grind to a coarser setting and you should see an even and consistent pour/extraction. Please advise if this helps. Alternatively, I can organise for one of our coffee experts to give you a quick demo over the phone??

Page 2 of 2

Get an answer from our members and Sunbeam representatives

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.