4 photos
Mercedes-Benz Vito W639.I

Mercedes-Benz Vito W639.I (2004-2011) Questions & Answers

3.0 from 22 reviews · View Statistics
Brand Manager for Mercedes-Benz? Register now and take advantage of ProductReview's Brand Management Platform!

9 questions from our users

sandor d.
sandor d.asked
Vito W639.I (2004-2011)

Hi im not sure but i guess the engine in my vito was replaced with a different one.the injector pump is gone and i realised when i took it off new support holes was drilled in the engine block ,this was a 646 pump which dasn't fit.i brought one 611,fits perfectly at the original holes but has only one sensor and the fuell feeds ad different. Is there any pump similar to 646 but different support holes? Thanks

No answers
Harbour Cat C.
Harbour Cat C.asked
Vito W639.I (2004-2011)

111 2009 short wheel base

Why does a bell chime when i start the car? Number seams to be going up im not at P20

Thanks love this van I had 4 V W and massive problems

Regards Col

No answers
cliffe s.
cliffe s.asked
Vito W639.I (2004-2011)

I need to replace the rear main oil seal in my 120cd long wheel base. Auto gearbox.
The first mechanic said it would take all day, and cost just shy of $1400. Useing dealer parts.... Admittedly its a franchise mechanic. Does this sound ball park accurate?
Q. Whats the average price to complete the work including new lubricants and std labour costs...
My next enquiry will be to a ex dealer mechanic. He aparently can save people lots of money when repairing mercs.... should be interesting

No answers
alby
albyasked
Vito W639.I (2004-2011)

hi there have a mercedes 2008 vito what after market front shockers do you reccomend for this vehicle

1 answer
Stevross A.
Stevross A.

Which ones did you buy as I want to put some in mine..was thinking gas ones

Rex
Rexasked
Vito W639.I (2004-2011)

I have a Mercedes Vito 111 of 2009. The problem is that I can not fix the exact hour this has appeared on the radio

No answers
Hendri J
Hendri Jasked
Vito W639.I (2004-2011)

I need help please! I have a vito w639 115 cdi. When i turn on the ignition all the electronics work (lights, dash lights, electric windows etc) as soon as I start the vehicle it idles and drives fine, but none of the electronics work. What could be the problem?

No answers
Marko S
Marko Sasked
Vito W639.I (2004-2011)

how to remove oil?

temperature sensor mercedes vito 639

No answers
Brenda
Brendaasked
Vito W639.I (2004-2011)

M/BENDS VITO 2006 115CDI, Started losing instrument display ,no a/con ,window control ,stopped the vehicle and restarted problem gone this happened twice, then twice on different trips the motor just died in the traffic, I found by putting my foot flat to the floor and revving it hard for about ten seconds it came good .I took it to work shop that services m/bends sprinters thinking they could help but they said they couldn't find any thing and referred to an injector specialist they have my van now for seven weeks and I'm still none the wiser...have heard off these problems....Any ideas?ThankYou

1 answer
Peter
Peter

My Vito a 2005 LWB crew cab goes into limp mode occasionally and the engine light comes on. I have had it checked and my merc mechanic couldn't find the reason.

Taz
Tazasked
Vito W639.I (2004-2011)

Mercedes Benz Vito 2005 115CDI Auto Trans.
Auto trans plays up when temp. reaches over 30 degrees celcius. Operates fine when I first use the van but as the day goes on and temp. increases the trans will not change gears correctly. It seems to be affected by the heat. The trans has recently been serviced by Mercedes Benz and no fault codes appeared. It seems to hang on from 1st to 2nd and into 3rd as well and nearly always in the heat it does not change into 4th until you at least get over 70 klm's per hour. When I let the vehicle rest for approximately 1 hour it seems to come good for a while even in the heat of the day. Any ideas?
Thank you!

2 answers
Arthur
Arthur

Hi Taz,

I have not come across this issue, but I do recommend that you keep away from the dealers, the only think that they know well is how to charge exorbitent fees, take it to a local mechanic.

Cheers
Arthur

Snr Pedro
Snr Pedro

Most likely the viscosity of the oil is the wrong grade. Or the torque converter.
If it seems to react to heat, then the oil is probably to thin.

See all Mercedes-Benz Vito questions

Get an answer from our members

Mercedes-Benz Vito W639.I (2004-2011)

Other Vans

Previous
Next
See all Vans

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.