??!

102 questions from our users

Laney B

Laney Basked

Ergorapido

We have what looks to be an orange colored unit. It is charged and the blue light is on but it will not start when pressing the start button. Is it not charged enough?

No answers
Ro

Roasked

Ergorapido

My Ergorapido stops after about 30 seconds. It is always thoroughly cleaned. It was purchased in December 2015

2 answers
Mrs B
Mrs B

Mine does the same. The battery never held charge. Absolute piece of junk battery. Won’t waste another cent on Electrolux products.

SSS
SSS

Well, did you call Electrolux and speak with them about your problem?

Sandrawunsch

Sandrawunschasked

Ergorapido Animal ZB3320P (18V, Chilli Red)

I went to use my Ergorapido and it won’t work
It’s fully charged but as soon as it starts it stops, with the stick and also without
I bought it last year....just after Mother’s Day (2019)
I clean it regularly so it’s not full of dust and rubbish

1 answer
SSS
SSS

Get your warranty book out and call the number in that.

Kaylene

Kayleneasked

Ergorapido

My Ergorapidio works fine as a handheld but wont work on the stick, starts then dies

1 answer
SSS
SSS

So did you call the number in your warranty book? Even if it is no longer under warranty, there is a service number which may be helpful.

marcelle e.

marcelle e.asked

Ergorapido Animal ZB3320P (18V, Chilli Red)

Over a period of time cleaner losing power and only working for a limited time which was getting less and now only working for approximately 1 minute. Do batteries need to be replaced?

1 answer
SSS
SSS

Call Electrolux Australia 1300366366

Mia

Miaasked

Ergorapido

After reading all Q&As here I cleaned the brush and every other part and the motorized brush is still not working. The self cleaner is also not working. I got them to work once briefly when I hold the vacuum in a specific angle and position but not anymore. The handheld vacuum works normally when I take it off and use it. Sometimes I get the vacuum to work for a few seconds up to maybe 15 s without the brush rotating but then soon the red light comes on and it shuts off. I can easily manually rotate the brush so it does not seem to be a mechanical issue. Any thoughts or ideas what to do?

2 answers
Melissa
Melissa

Put it back into it's docking station and leave it overnight on charge, try it the next day and if it's still giving you issues then phone the electrolux company for advice, OR if it's still under warranty take it back to the store of purchase, they may be able to tell you what's going on, also if you have had the brush out to clean it, you may not have put it back in correctly after the clean ? but it looks like their could be an issue with either the charging dock, it may not be charging it properly and so not enough power to rotate the brush also have you put the brush back in correctly ? when I took the brush out of mine to clean I did notice it had to be put back the same way it came out, so if you have picked up the brush to insert it you may be trying to put it back in the wrong direction or it could also be a problem with machine itself. Good luck.

Mia
Mia

I have had it in charged overnight and whenever I do not use it but it does not help. I’m also sure that I put the brush back the right way and I just tried to check and could not even figure out any other way it could fit. It’s weird that when I try to turn it on the red light comes on and it shuts off. Then, I have to press it on multiple times (around 5-8 times) until I get it turn on without the red light and so that it stays on. Also, the floor light blinks shortly whenever I am able to turn it on but quickly light goes off but the vacuum still keeps sucking without the brush moving. I think the brush may actually rotate for a second when the floor light is momentarily on but it is hard to see as it happens so quickly. It’s almost like starting a motorcycle with a few “Bruum” sound until the vacuum turns on. So I can use the vacuum this way without the brush but I feel it is not sucking that well without the brush rotating. I bought the vacuum 2 years ago so I may not have a warranty anymore valid. But thanks for your advice, I’ll look for the company number to call.

Glynis

Glynisasked

Ergorapido

Interesting to hear all these complaints. My previous one, Type CT96 ZB2815 ML13 PNC 900 164 378 S. no. 83750126 (hardly used - it was at holiday home) had no suction after a short while, and with little little power. Thought maybe had just been unlucky and have recently bought another one which I am starting to regret after reading everyone with the same problems. Suggest to all - look for another make!!

No answers
Kerry F.

Kerry F.asked

Ergorapido

I would like to know how to remove the brush inside the recharge stand

1 answer
Melissa
Melissa

grab the brush and pull it towards you slightly and upwards, it should be that easy, if not then something isn't right.

Mary Bruno

Mary Brunoasked

Ergorapido

Why my Electrolux ergorapido keep shutting off?

No answers
Phyllis G.

Phyllis G.asked

Ergorapido

Hi there I am looking to change the inner filter and when I go to buy the filters they don't seem to have the outer casing. Does the outer casing come off or where can I buy a filter with the outer frame
Thanks
PG22

No answers
Melissa

Melissaasked

Ergorapido Allergy ZB3311 (18V, Titan Blue)

Is the detachable handheld unit of this vacuum suitable for cleaning carpeted stairs and is their a n attachment for this ?

No answers
Melissa

Melissaasked

Ergorapido Allergy ZB3311 (18V, Titan Blue)

Is the handheld detachable bit suitable for doing carpeted stairs ?

No answers
Stella B

Stella Basked

Ergorapido

mine was left on charge for an extended period of time, now it doesn't seem charged at all. What to do?

No answers
Hisashi

Hisashiasked

Ergorapido

My vacuum keeps turning off after just start to vacumm? And the brush also stops.

No answers
Frans L.

Frans L.asked

Ergorapido

After 18 months Ergorapido ZB3101 will run only 1 minutes. New batteries, still only 1 min. of running. Charger gives 14V without load. Does the chip on circuit board have a "planned obsolescence" program? At least it have a clock, because charging light blinks 1 times per minute when battery is "full".

No answers
Sally

Sallyasked

Ergorapido

Does it have an on off switch that doesn’t need to be held down

2 answers
Même
Même

Hi Sally, I just press the on button and let go, then it’s on until I press it again to turn off. You shouldn’t need to hold it on. If that’s the case I would take it back to the place you bought it.

Sally
Sally

Thanks, no I haven’t bought one yet, but others I have tried ,need to be held and with arthritis in my hands I can’t manage it.

Jill

Jillasked

Ergorapido

How do you clean filter

1 answer
Même
Même

Assuming you know how to empty cassette, remove outer cover of casette and then take off next cover (tricky) which reveals the inner filter. I used the brush from my dustpan/brush set and gave it a thorough brush in all directions. Then I gave the smaller end of the cartridge a couple of good whacks using the hard ridge of the brush which knocked even more dust. Suggest you clean regularly or you get a big build up of dust pretty quickly. If I could include photos it would help but don’t think I can.

Renee B.

Renee B.asked

Ergorapido

My Ergorapido is only 18 month old and will not charge. I put it on the charger and the 3 orange lights flash like it is charging. When I turn it on it goes for about 1 second then stops. The hand held unit doesn't work either when I take it off so it is not charging at all. if I leave it on the charger for over 48 hours the light turns red and I have no charge at all!! Surely this should not happen after only 18 months????

No answers
Rosalie N.

Rosalie N.asked

Ergorapido

where does the end of the charger go on the machine once i plug in the adaptor on a outlet on the 2 in one mini vacuum?

1 answer
Wenddee
Wenddee

I think mine came attached to the base. It seems to be inside the base.

Wenddee

Wenddeeasked

Ergorapido

I just wanted to say that I had the same red light turning on after a few seconds as mentioned above. The handheld unit worked fine. I managed to fix it as set out below.

I cleaned the brush carefully and the ends and checked I could see through the hose pipe and it was clear. I washed the filter.

I turned the stick upside down to check if the brush was rotating while the unit was turned on. It was not. I took the brush out again and checked it (all clear). I then put the brush back in and manually rotated it - it was very stiff for the first rotation and almost impossible to turn. Then it started to turn smoothly. I then turned the vacuum on and it was perfect again. There must have been something I could not see at the ends. Anyway, it worked. All fixed :)

1 answer
Greg K.
Greg K.

I had this same problem and it didn’t occur to me that the brush roll wasn’t moving. I did what you suggested and it’s working again. Thank you so much!

Page 1 of 6

Get an answer from our members and Electrolux representatives

ProductReview.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ProductReview.com.au may earn commissions for products/services purchased via affiliate links.